Timesheet updates with 0 hours

Feb 3, 2010 at 1:28 PM
Edited Feb 3, 2010 at 1:33 PM

Hey Steve,

I've been trying this solution as an update to the 1.5 release of the timesheet autostatus service.  The issue we've encountered is documented in the autostatus timesheet service blog, but I'll work through the details here.  Here's the scenario:

1) We create and save a timesheet with 2 hours for a specific task.

2) We realize we've updated the task incorrectly and insert a 0 in place of the 2 in the existing timesheet.

3) It appears that the timesheet is updated, but the hours are not zeroed out on the task update.

Is there a setting we can change to force this scenario to apply the 0 hour updates to tasks.  If so, can you point us in the right direction?

 

Thanks,

Jim Wood

Enterprise Application Manager - Hearst Business Media

Feb 4, 2010 at 3:39 PM
Edited Feb 4, 2010 at 3:40 PM

We've managed to get this working by enabling the process all lines feature.  The unfortunate side effect is that anytime a user saves a timesheet, the PM receives an email that contains all lines in the current timesheet.  Not the end of the world, but creates more noise than is necessary.

Coordinator
Feb 10, 2010 at 6:11 PM

Sorry again for taking so long to respond -- my external spam filter was trapping these messages, and I don't check it every day.

This is an unfortunate side effect of this feature. I plan to try and rework this functionality at some point to eliminate this shortcoming, but alternate approaches introduce other problems.

Steve